Problem in Checkout of solution.xml

Topics: Build Template, Continuous Integration
Jan 5, 2016 at 1:28 PM
Edited Jan 5, 2016 at 1:29 PM
I am getting below error constantly when i build my CRM solution on buold server to pack CRM solutions using mapping file. i did map solution files folder to workspace in build definition. i also tried to run tf workspace /collection command to resolve it but all in vain :(

any help would be much appreciated

___Unable to determine the workspace. You may be able to correct this by running 'tf workspaces /collection:TeamProjectCollectionUrl'.
Set-XrmSolutionVersionInFolder : Access to the path 'C:\a\src\Sample\ExtractSolution\Other\Solution.xml' is denied.
At C:\a\src\xRMCIFramework_6.1.0.0\PowerShell\DynamicsCRMTemplateBuildScript.ps1:189 char:9
  • Set-XrmSolutionVersionInFolder -SolutionFilesFolderPath $LocalSolutionPa ...
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  • CategoryInfo : NotSpecified: (:) [Set-XrmSolutionVersionInFolder], UnauthorizedAccessException
  • FullyQualifiedErrorId : System.UnauthorizedAccessException,Xrm.Framework.CI.PowerShell.SetXrmSolutionVersionInFo
    lderCommand___
Jan 20, 2016 at 10:32 PM
Hi,
Have you got the solution,I'm also getting the same error
Coordinator
Feb 11, 2016 at 10:43 PM
just saw this now some issue with email notification from here.

I hope you have been able to resolve this.
Feb 25, 2016 at 12:27 AM
thanks for that. yes i did . This is a bug in VS online.

Mar 15, 2016 at 3:04 PM
Hi,
My Visual Studio is on premise but still I'm getting the same error.
Any Suggestions?