This project is read-only.

Import Module error

Topics: PowerShell Cmdlets
Nov 10, 2014 at 11:04 AM
Edited Nov 10, 2014 at 11:04 AM
Hi, as a complete non-techie I am trying to follow the instructions from the xRM framework but I run into trouble already when I try to use the 'import-module' command in Powershell. I get this message:

Import-Module : Could not load file or assembly 'file:///C:\Users\avelde77\TFS\CRM2011\SCC AV\TFS BUILD TEMPLATES\xRMCI
Framework_6.1.0.0\PowerShell\Xrm.Framework.CI.PowerShell.dll' or one of its dependencies. Operation is not supported. (
Exception from HRESULT: 0x80131515)
At line:1 char:14
  • Import-Module <<<< ".\Xrm.Framework.CI.PowerShell.dll"
    • CategoryInfo : NotSpecified: (:) [Import-Module], FileLoadException
    • FullyQualifiedErrorId : System.IO.FileLoadException,Microsoft.PowerShell.Commands.ImportModuleCommand
We are light on Powershell knowledge where I am currently working, any thoughts are very welcome!

Thank you

Nov 15, 2014 at 11:22 AM
Nov 27, 2014 at 9:06 AM
What worked for me on Windows 8.1 was unblocking the downloaded .zip archive (before extracting the files).
All I had to do was right-click it, click Properties, then click Unblock.
Feb 25, 2015 at 6:36 PM
Thx for sharing.